+ Antworten
Ergebnis 1 bis 2 von 2
  1. #1

    Hilfe, erster lokaler Server funktioniert nicht richtig, z.B. Essentials-Fehlermeldun

    Hallo allerseits,

    ich möchte unbedingt mit VoxelSniper (WorldEdit reicht mir nicht) und Minecraft 1.12 eine Landschaft planen.
    Offensichtlich gibt es VoxelSniper leider nicht für Singleplayer.
    Der einzige Weg scheint jetzt zu sein, dafür einen eigenen lokalen Server zu nutzen.
    Leider hab ich sowas bisher noch nie gemacht.
    Daher wundert es mich auch nicht, dass meine ersten Bemühungen mit Unterstützung diverser YouTube-Videos (die allerdings alle schon mehrere Jahre alt sind) bisher gescheitert sind.

    Nachdem ich Craftbukkit 1.12, bPermissions und Essentials (möglichst jeweils die neueste Version) heruntergeladen hatte und in die entsprechenden Ordner verschoben und gestartet hatte (und vorsichtig in diverse config.yml-Dateien u.ä. herumedititiert hatte), konnte ich immerhin eine in den world-Ordner kopierte Kreativ-Map betreten. Allerdings kam die Meldung "Essentials failed to load please read the log-file". Irgendwelche Befehle haben auch überhaupt nicht funktioniert.
    Im Log finde ich dann unter anderem die Meldung :"Error occurred while enabling Essentials v2.13.1 (Is it up to date?)"
    Das bringt mich zu der Frage, ob ich die richtigen Essentials verwende. Allerdings hab ich nirgendwo eine Antwort auf die Frage gefunden, welche Essentials ich für Minecraft 1.12 verwenden muss. Es sieht aber so aus, als könnte man Essentials nur bis Minecraft 1.8 verwenden.
    Und so komme ich jetzt einfach nicht weiter.

    Eine vollständige Erläuterung, wie man einen Bukkit 1.12-Server zusammenbastelt, wäre optimal. Auch hier finde ich bisher im Netz leider nichts.
    Von fix -und fertig konfigurierten Servern zum Download wird ja auch abgeraten, und da hab ich bei YouTube auch nur einen Fund, teilweise in Russisch, gehabt, was mir etwas suspekt war, sonst hätte ich das mal ausprobiert.
    Obwohl man hier einige Infos zu Servern finden kann, hab ich im Forum nach einer Antwort, die mich bei meinem Problem wirklich weiterbringt, bisher vergeblich gesucht.

    Ich hoffe sehr, dass mir hier jemand weiterhelfen kann. Dabei bitte bedenken, ich kenne mich zwar in Minecraft selbst und Nutzen von Servern einigermaßen aus, in der Erstellung von Servern aber bisher überhaupt nicht.

    Gruß
    Legosunny

    Edit: (12.10.2017 um 18:42)

    In der Zwischenzeit hab ich jetzt einen neuen Versuch unternommen und anstelle von Essentials EssentialsX installiert.
    Damit war die Fehlermeldung verschwunden. EssentialsX konnte fehlerfrei geladen werden, und es war auch die Nutzung des Chats möglich.
    Leider hatte ich aber noch keine Möglichkeit, irgendwelche Befehle zu verwenden, obwohl in diversen (da sieht man schon, dass ich keine Übersicht habe) Config-Dateien Berechtigungen eingetragen waren und ich mich mit meinem Namen in der user.yml als Owner eingetragen hatte, möglicherweise ein kompletter Blödsinn.
    Jetzt hab ich schnelle Soforthilfe von einem Spielerkollegen erhalten. Wie vermutlich fast jeder außer mir weiß, genügt die Eingabe op <Spielername>, um dem Serverstarter alle Rechte zu ermöglichen.
    Da ich nicht wirklich einen Server betreiben will, genügt mir diese Krücke erst mal.
    Jetzt hoffe ich, dass ich VoxelSniper für Bukkit installieren kann (was nicht so einfach scheint, wie ich gedacht habe. Gibt's das überhaupt für Bukkit??).
    Dann wäre ich am Ziel

    Gruß
    Legosunny

    Edit: (13.10.2017 um 10:58)

    Hab jetzt Voxelsniper mit Bukkit 1.9 installiert, vermutlich der letzten MC-Version, wo das möglich war. Installation mit Sponge ist bei mir leider gescheitert. Aber so reicht es für mich auch.
    Nachdem hier wohl niemand antworten wird, könnt Ihr hier wieder dichtmachen, wenn Ihr wollt.

    Gruß Legosunny

  2. #2
    DEV Avatar von Black__Hole
    Registriert seit
    15.09.2011
    Beiträge
    3.913
    Voxelsniper läuft durchaus mit Spigot 1.12.2. Aber verzichte mal auf dieses bPermissions.


+ Antworten