+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 11
  1. #1
    Holzfäller
    Registriert seit
    12.10.2017
    Beiträge
    5

    Unerwartetes Problem, Spiel abgestürzt, noch vor dem Start.

    Liebe Minecraft-Begeisterte,

    Kurz und knapp: Dell Laptop Inspiron 15R SE 7520 , Windows 7, Grafikkarte AMD Radeon HD 7730M, 8GB DDR-Ram.
    Problem aktuell, mit einem von Windows installierten Treiber startet Minecraft.
    Mit diesen funktionieren Steam und alles weitere (Emulatoren etc.) aber nicht.
    Mit dem aktuellsten Treiber (Direkt von der AMD Webseite), welchen ich auch gern auf dem Laptop behalten mag, kommt diese Fehlermeldung:

    "Ein unerwartetes Problem ist aufgetreten und das Spiel ist abgestürzt.
    Wir entschuldigen uns für die Unannehmlichkeiten"

    -----------------------------------------------------------------------------


    07:43:31 launcher Preparing to launch minecraft client for 1.12.2
    07:43:32 launcher Checking installations.
    07:43:32 launcher Minecraft client 1.12.2 is ready to start.
    07:43:32 launcher Starting!
    07:43:33 launcher Using default game log configuration client-1.12.xml (outputs XML)
    07:43:36 bib Setting user: Calimdor_Dragon
    07:43:38 bid Skipping bad option: lastServer:
    07:43:38 bib LWJGL Version: 2.9.4
    07:43:38 bib Couldn't set pixel format
    org.lwjgl.LWJGLException: Pixel format not accelerated
    at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelForma t(Native Method)
    at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat (WindowsPeerInfo.java:52)
    at org.lwjgl.opengl.WindowsDisplay.createWindow(Windo wsDisplay.java:247)
    at org.lwjgl.opengl.Display.createWindow(Display.java :306)
    at org.lwjgl.opengl.Display.create(Display.java:848)
    at org.lwjgl.opengl.Display.create(Display.java:757)
    at bib.at(SourceFile:622)
    at bib.aq(SourceFile:458)
    at bib.a(SourceFile:404)
    at net.minecraft.client.main.Main.main(SourceFile:123 )

    -------------------------------------------------------------------------------------

    Bisher habe ich stundenlang Google durchforstet und Freunde gefragt.
    Java ist auf dem aktuellsten Stand und meine Grafikkarte auch.

    Aktuell denke ich...Irgendwie hat es etwas mit OpenGL zu tun
    (Diese Funktion ist bei After Effects CS6 auch ausgegraut, ich dachte daher ich hab das gar nicht in der Graka),
    irgendwie hat es etwas mit der Grafikkarte bzw. dessen Software zu tun,
    kontrollierter Verschleiß bzw. deaktivieren von Funktionen. Ich hatte alle Treiber mit DDU gelöscht,
    musste aber eine Systemwiederherstellung machen, da danach auch die neuen Treiber gespinnt haben.

    Bin daher nun etwas am Ende, denn ich bin eigentlich zufrieden mit meinem Laptop, es hat bisher
    alles funktioniert (außer vlt. OpenGL bei After Effects CS6) das einzige, das wirklich nicht läuft, ist Minecraft.

    Da ich nun am Ende meiner Möglichkeiten bin, hoffe ich hier sehr auf freundliche Unterstützung,
    damit ich auch in den Genuss von Minecraft kommen kann, ohne vorher meinen Laptop zu zerstören.

    Ich bitte um euer Verständnis, falls etwas unklar ist, ich beantworte jede Frage und freue mich,
    wenn wir gemeinsam Minecraft zum laufen bringen :-).
    Geändert von Calimdor (12.10.2017 um 23:15 Uhr)

  2. #2
    Obsidianforscher Avatar von Neui
    Registriert seit
    06.04.2011
    Beiträge
    2.093
    Von wo hast du deine Grafiktreiber installiert? Die Treiber, die direkt von Windows 7 kommen haben keine OpenGL Unterstützung. Installiere dir mal die Grafiktreiber direkt von der AMD Webseite: 64-bit (da du 8 GiB RAM hast, denke ich, dass du die 64-bit Version von Windows 7 nutzt. Du brauchst das "Crimson ReLive" nicht, nehme mal die "AMD Minimal Setup")
    Ich brauche keine Signatur..

  3. #3
    Holzfäller
    Registriert seit
    12.10.2017
    Beiträge
    5
    Zitat Zitat von Neui Beitrag anzeigen
    Von wo hast du deine Grafiktreiber installiert? Die Treiber, die direkt von Windows 7 kommen haben keine OpenGL Unterstützung. Installiere dir mal die Grafiktreiber direkt von der AMD Webseite: 64-bit (da du 8 GiB RAM hast, denke ich, dass du die 64-bit Version von Windows 7 nutzt. Du brauchst das "Crimson ReLive" nicht, nehme mal die "AMD Minimal Setup")
    Vielen Dank für deine Antwort. Meinen aktuellen Grafiktreiber habe ich von der AMD Webseite installiert. Wenn ich im Gerätemanager den Treiber aktualisiere - warum auch immer das möglich ist, wenn ich ja eigentlich von AMD den neusten Treiber installiert habe - dann wird von Windows ein Treiber installiert, mit welchen Minecraft startet.
    ABER Steam und alles andere Grafiklastige funktioniert dann nicht mehr, deswegen kann das keine Lösung sein.
    "Crimson ReLive" kann ich bei der Benutzer definierten Installation des Grafiktreibers nicht auswählen bzw. nicht nicht installieren.
    Eine Option für "AMD Minimal Setup" gibt es auch nicht.

    Aktuell habe ich versucht alle Treiber über Dell zu installieren, natürlich hat das nicht funktioniert. Der Laptop ist vier Jahre alt und einen aktuellen Support gibt es nicht,
    angeblich läuft nach allen Systemtests von Dell das System Einwandfrei. Ich werde nun aber zum sicher vierten mal eine Systemwiederherstellung durchführen, da immer wenn ich alle Treiber mit DDU lösche und eben versuche alles neu zu installieren, die Grafikkarte deaktiviert wird, weil die Software nicht funktioniert, whatever,
    weil eigentlich lief ja alles, nur Minecraft nicht :/, daher die Systemweiderherstellung vor dem ganzen Treiberzirkus.

    Würde mich dennoch weiterhin über Lösungsvorschläge freuen :3.
    Geändert von Calimdor (13.10.2017 um 03:12 Uhr)

  4. #4
    Obsidianforscher Avatar von Neui
    Registriert seit
    06.04.2011
    Beiträge
    2.093
    Hast du die Treiber über die automatische Treibererkennung und -installation bei AMD benutzt? (Direktlink, 50 MB )
    Außerdem habe ich geschrieben, dass du das ReLive nicht benötigst, da es optional ist und nicht für die Funktionen benötigt wird.
    Hast du zumindest das Readon Einstellungen-Programm? (Üblicherweise im Infofeld/Systemtray, also die Symbolen unten rechts, das Icon ist rot)
    Ich brauche keine Signatur..

  5. #5
    Holzfäller
    Registriert seit
    12.10.2017
    Beiträge
    5
    Ich habe den Treiber über die automatische Treibererkennung installiert, ja, unten rechts kann ich auf das Radeon Menü zugreifen.
    Falls es in diesem Menü Einstellungen gibt, die das Spiel zum laufen bringen, das wäre ein Traum :3.

  6. #6
    Obsidianforscher Avatar von Neui
    Registriert seit
    06.04.2011
    Beiträge
    2.093
    Das heißt dass die Treiber installiert sein sollten. Da du ein Laptop benutzt, denke ich mal, dass du 2 Grafikkarten besitzt (die andere ist wahrscheinlich eine Intel GPU) und Minecraft die Intel GPU nutzt, welche anscheinend keine Treiber mit OpenGL installiert hast. Kannst du mal nachschauen, ob du Minecraft mit der AMD Grafikkarte starten kannst? Eventuell findest du es in den Readon Einstellungen under Spiele. Suche nach "Minecraft" oder "java".
    Ich brauche keine Signatur..

  7. #7
    Holzfäller
    Registriert seit
    12.10.2017
    Beiträge
    5
    Ja, es sind zwei Grafikkarten. Das läuft über Umschaltbare Grafiken und wird im Menü, so wie ich das bisher verstanden habe, durch die erforderte Leistung bestimmt. Wenn ich die Leistung des Spiels oder Programms hoch stelle, wird von der AMD Grafikkarte geladen. Hier einmal ein Bild von meinen aktuell möglichen Einstellungen:



    Da steht sogar etwas von OpenGL :/, aber mit den im Bild angezeigten Einstellungen kommt weiterhin die im ersten Post beschriebene Fehlermeldung.
    Geändert von Calimdor (13.10.2017 um 16:20 Uhr)

  8. #8
    Obsidianforscher Avatar von Neui
    Registriert seit
    06.04.2011
    Beiträge
    2.093
    Hm, ok. Kannst du Minecraft und/oder "java" (oder "javaw") die Leistung auf "hoch" stellen (so dass deine AMD Grafikkarte benutzt wird)? Soweit ich weiß wird gerne Java, die Sprache in der Minecraft geschrieben ist und läuft, wird niedrig eingestuft.
    Falls du die Datei angeben kannst auf der die Grafikkarte genutzt werden soll, gebe mal die <Installationspfad-in-C:\Programme\Minecraft>\runtime\jre-x64\bin\javaw.exe. Eventuell wird der Launcher ausgewählt, welches nur Java mit den richtigen Dateien etc. startet.

    Vielleicht mal auch die Intel Grafiktreiber installieren (oder alternativ direkt von der DELL Seite, welches aber von 2013 stammt. Sieht so aus als würde es die 2. Datei sein, "Video_Intel_W74_X09_A03_Setup-HWM8D_ZPE.exe"), damit du auch dort OpenGL nutzen kannst. Minecraft wird aber wahrscheinlich langsam laufen.
    Ich brauche keine Signatur..

  9. #9
    Holzfäller
    Registriert seit
    12.10.2017
    Beiträge
    5
    Java und Javaws , wie Minecraft auf Hochleistung gestellt, gleiches Problem.
    Treiber über Dell nochmal aktualisiert, alles auf Energiesparend gestellt, gleiches Problem.

    Was steht denn eigentlich genau in der Fehlermeldung vom Anfangs-post?

    Ich vermute nun wirklich auch, das AMD bei älteren Grafikkarten Funktionen ungesehen deaktiviert. Zumindest schaut es auf dieser Liste so aus.
    Eigentlich habe ich aber auch eine AMD Radeon HD 7730M, wobei das AMD bei AMD Radeon HD 7700 Serie rein steckt.
    Auf der Dell Webseite ist der letzte Treiber speziell für meine Grafikkarte von 2013, Windows 7 deaktiviert die Grafikkarte dann aber und dann geht gar nichts mehr :/.

  10. #10
    Obsidianforscher Avatar von Neui
    Registriert seit
    06.04.2011
    Beiträge
    2.093
    Zitat Zitat von Calimdor Beitrag anzeigen
    Was steht denn eigentlich genau in der Fehlermeldung vom Anfangs-post?
    Es bedeutet, dass die Grafikkarte das Pixel Format (scheint sowas wie Bildformat zu sein) nicht beschleunigt(/benutzen) kann(/will). (Dazugehöriger Code)

    Die Liste zeigt nur die OpenGL "Erweiterungen" für die Grafikkarten unter verschiedene Treiberversionen (und Betriebssystem). Einer der wichtigen Daten ist "GL_VERSION", welches zeigt welche OpenGL Version es unterstützt, welches 4.4 ist. Minecraft benutzt minimum OpenGL 1.3 und seit einer 1.7-Version OpenGL 2.1, aber es wird 4.4 empfohlen.

    Gehe mal in den Launcher auf die Profileinstellungen und aktiviere "Java-Programmdatei" und setze den Pfad die java.exe Datei die du davor den "Hochelsitungsmodus" zugewiesen hast. Eventuell auch mal den Launcher auf den Hochleistungsmodus setzen, falls nicht so ist.

    Falls dies auch nicht klappt, bin ich ratlos.
    Mojang sagt nur dass man die Grafiktreiber aktualisieren sollte. In seltenen Fälle könnte dies auch sein dass es ein Eingabegerät wie ein Kontroller sein sollte oder als Kontroller interpretiert wird (z. B. ein Headset wird als Kontroller erkannt) und eventuell solche Geräte aus dem Computer rausstecken sollte bevor man Minecraft startet, aber ich denke dass dies nicht so ist.
    Es gibt noch "Software OpenGL" die von Windows aus das Rendering übernimmt. Da es jedoch wahrscheinlich wirklich in Software ist, also dass die Grafikkarte nicht wirklich benutzt wird, wird es langsam sein und könnte auch nicht funktionieren. Falls du es trotzdem versuchen möchtest, in den Profileinstellungen des Minecraft Launchers, aktiviere "JVM-Argumente" und setze "-Dorg.lwjgl.opengl.Display.allowSoftwareOpenGL=true " ein.
    Ich brauche keine Signatur..

+ Antworten