PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Multiverse und Permissions



mcandy007
01.11.2011, 21:43
Servus,

Ich habe dieses Forum aufgesucht da ich paar kleine Probleme mit meinem Bukkitserver(1337 (MC: 1.8.1)) habe.

Als Rechtesystem läuft auf diesem:
Permissions 3.1.6 http://forums.bukkit.org/threads/inactive-admn-dev-permissions-3-1-6-the-plugin-of-tomorrow-935.18430/

Da ich nun zusätzlich eine FreeBuild Welt im Creativ modus einrichten wollte habe mich für Multiverse 2 und Multinv entschieden.

Ingame als OP funktioniert alles super.

Habe nun der Standartgruppe der Mitspieler die Rechte:


- 'multiverse.access.*'
- 'multiverse.teleport.self.*'


selbst als Admin ohne op Rechten jedoch mit den Permissions:


- '*'
- 'multiverse.*'

habe ich keine Rechte.

Es scheint so als würde Permissions ignoriert werden.

Die storageconfig in Permissions sieht so aus:


permissions:
storage:
type: YAML
world-inheritance:
World_nether: World
FreeBuild: World

Die config von Multiverse:


worldnameprefix: true
enforceaccess: true
enforcegamemodes: true
bedrespawn: true
version: 2.4


Wird Permissions nicht unterstützt habe ich was übersehen?

Vielen Dank im voraus!

MFG

klekle204
19.01.2012, 16:12
ich schätze weil das hier schon ein jahr da ist hat keiner ne lösung ich hab das selbe problem

Damarus87
19.01.2012, 16:22
Poste deine config dann kann dir geholfen werden!

klekle204
19.01.2012, 20:42
multi verse portal:
wand: 271
useonmove: true
portalsdefaulttonether: true
enforceportalaccess: true
portalcooldown: 1000
version: 2.6

Group manager:
Admin:
default: false
permissions: []
inheritance:
- moderator
- g:essentials_admin
- g:bukkit_admin
- multiverse.portal.access.*
- '*'
- multiverse.teleport.*

tr4st
19.01.2012, 22:32
Ich sehe den Fehler.

inheritance:
- moderator
- g:essentials_admin
- g:bukkit_admin
- multiverse.portal.access.*
- '*'
- multiverse.teleport.*
Alles nach "- moderator" gehört dort nicht mehr hin! inheritance: besagt, dass er dieser Gruppe die Rechte der angegebenen Gruppe geben soll plus die eigenen.
Damit man nicht alle Rechte öfters vergeben muss, sondern eine sogenannte Vererbung nutzen kann.

Welches Permissions Plugin nutzt du?

Fritz2d
19.01.2012, 23:36
Welches Permissions Plugin nutzt du?



Group manager:
Admin:
default: false
permissions: []

;)

Richtig sieht ein Admin bzw. Op so aus:

Admin:
default: false
inheritance:
permissions:
- '*'

Wenn du in deinem Fall alles können möchtest, kannst du dir inheritance komplett sparen das '*' verpasst dir alle Rechte. (Das selbe erreichst du in dem du deinen Namen in der ops.txt einträgst) Es gibt nur ganz, ganz, ganz wenige Plugins, bei denen das nicht funktioniert - Multiverse gehört nicht dazu. Was du beschreibt hört sich eher danach an, dass dein Permissionsfile nicht gelesen werden kann. Das ist YAML und reagiert extrem allergisch auf Tabs. Nutze am besten Notepad++ zum bearbeiten von Yaml-Files, da sieht man meist sofort, wenn man einen Fehler macht. Halte dich außerdem akribisch an die Vorgaben, also Anzahl der Leerzeichen einhalten - keine Sonderzeichen! (Wenn verwendet dann in UTF-8 abspeichern) Hast du nur einen einzigen Fehler in einem *.yml file funktioniert es bereits nicht mehr. Also überprüfe die gesamte Datei.

Übrigens:
Möchtest du, dass auch ein Admin nicht alle Rechte hat, darf dein Name auf keinen Fall in der ops.txt stehen, sonst funktioniert es nicht. Du kannst auch mit einem Minus davor Rechte einzeln entziehen, was bei einem Admin i.d.R. mehr Sinn macht. Also z.B.:

permissions:
- '*'
- -essentials.item

(Damit könntest der admin sich z.B. nicht mehr selbst Items ausgeben.. wenn essentials genutzt wird.)

klekle204
20.01.2012, 16:18
zuerst danke ich benutze ++ und weiss das mit den tabs also was heisst das inheritance eigentlich

Edit: (20.01.2012 um 15:25)

Hä es funktioniert nicht meine config sieht jez so aus
Admin:
default: false
permissions:
- '*'
inheritance:
-moderator
info:
prefix: '&9'
build: true
suffix: ''

ich verstehe es nicht

Edit: (20.01.2012 um 15:40)

ok problem fast gelöst
teleportintercept ist jetzt auf false aber ich kann nur rtel teleporter nutzen wenn ich in die hölle bzw end will kann ich immer noch net rein

501.legion
21.01.2012, 15:56
Ich habe auch ein ähnliches Problem:

Admins:
default: false
info:
prefix: ''
suffix: ''
build: true
inheritance:
permissions:
- '*'

Nun wollte ich als Mitglied der Gruppe "Admins" (ich besitze auch InGame alle Rechte) durch ein Portal reisen, welches zuvor mit den Rechten aus ops.txt noch prima funktionierte, doch bekam ich stattdessen die Meldung: "You don't have access to go here....". Wenn ich nun die Welt per Befehl wechseln will, kommt die Meldung "You do not habe any of the required permission(s):" und eine Reihe von Permissions. Auch wenn ich diese alle in der Gruppe eintrage, passiert nichts. Ähnliches passiert auch bei dem Befehl "/help".

tr4st
21.01.2012, 16:00
Poste uns mal bitte deine permissions.yml, dann können wir schauen woran es liegen mag.

klekle204
21.01.2012, 16:35
da steht nix drinne ich nutze group manager

tr4st
21.01.2012, 16:39
Dann poste halt die Groupmanager Config... xD

klekle204
22.01.2012, 19:04
settings:
config:
# With this enabled anyone set as op has full permissions when managing GroupManager
# The user will be able to promote players to the same group or even above.
opOverrides: true

# If enabled any plugins bukkit permissions which default to true will be left enabled.
# If the player is op any permissions set to Op will follow suit.
bukkit_perms_override: false

# Default setting for 'mantoglevalidate'
# true will cause GroupManager to attempt name matching by default.
validate_toggle: true

data:
save:
# How often GroupManager will save it's data back to groups and users.yml
minutes: 10
# Number of hours to retain backups (plugins/GroupManager/backup)
hours: 24

logging:
# level of detail GroupManager will use when logging.
# Acceptable entries are - ALL,CONFIG,FINE,FINER,FINEST,INFO,OFF,SEVERE,WARNI NG
level: INFO

mirrors:
# Worlds listed here have their permissions mirrored in their children.
# the first element 'world' is the main worlds name
# subsequent elements '- world_nether' are worlds which will use the same
# user/groups permissions as the parent.
world:
- world
- world2
- world3
# world4:
# - world5